HomePentest-Tools.com Logo

Adobe Flash Player Multiple Vulnerabilities September-2011 (Mac OS X) CVE-2011-2426CVE-2011-2427CVE-2011-2428CVE-2011-2429CVE-2011-2430CVE-2011-2444

Severity
Not available
CVSSv3 Score
Not available
Vulnerability description

Adobe Flash Player is prone to multiple vulnerabilities.

Risk description

The flaws are due to - Stack-based buffer overflow in the ActionScript Virtual Machine (AVM) component, allows remote attackers to execute arbitrary code via unspecified vectors. - logic error issue, allows attackers to execute arbitrary code or cause a denial of service (browser crash) via unspecified vectors. - security control bypass, allows attackers to bypass intended access restrictions and obtain sensitive information via unspecified vectors - logic error vulnerability, allows remote attackers to execute arbitrary code via crafted streaming media - Cross-site scripting (XSS) vulnerability, allows remote attackers to inject arbitrary web script or HTML via a crafted URL. Successful exploitation will let attackers to execute arbitrary code or cause a denial of service.

Recommendation

Upgrade to Adobe Flash Player version 10.3.183.10 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Sep 22, 2011
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available