HomePentest-Tools.com Logo

Adobe Photoshop BOF and Use After Free Vulnerabilities (Mac OS X) CVE-2012-2027CVE-2012-2028CVE-2012-2052CVE-2012-0275

Severity
Not available
CVSSv3 Score
Not available
Vulnerability description

Adobe Photoshop is prone to buffer overflow and use after free vulnerabilities.

Risk description

The flaws are due to - An insufficient input validation while decompressing TIFF images. - An input sanitisation error when parsing TIFF images can be exploited to cause a heap based buffer overflow via a specially crafted file. Successful exploitation will allow attackers to execute arbitrary code.

Recommendation

Apply patch for Adobe Photoshop CS5 and CS5.1, or upgrade to Adobe Photoshop version CS6 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Sep 4, 2012
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available