HomePentest-Tools.com Logo

Adobe Photoshop CC Multiple Vulnerabilities August19 (Mac OS X.) CVE-2019-7968CVE-2019-7969CVE-2019-7970CVE-2019-7971CVE-2019-7972CVE-2019-7973CVE-2019-7974CVE-2019-7975CVE-2019-7976CVE-2019-7977CVE-2019-7978CVE-2019-7979CVE-2019-7980CVE-2019-7981CVE-2019-7982CVE-2019-7983CVE-2019-7984CVE-2019-7985CVE-2019-7986CVE-2019-7987CVE-2019-7988CVE-2019-7989CVE-2019-7990CVE-2019-7991CVE-2019-7992CVE-2019-7993CVE-2019-7994CVE-2019-7995CVE-2019-7996CVE-2019-7997CVE-2019-7998CVE-2019-7999CVE-2019-8000CVE-2019-8001

Severity
CVSSv3 Score
9.8
Vulnerability description

Adobe Photoshop CC is prone to multiple vulnerabilities.

Risk description

Multiple flaws are due to: - Heap overflow errors, - Type confusion errors, - Out of bound read errors, - Command injection errors and - Out of bound write errors. Successful exploitation will allow remote attackers to execute arbitrary code in the context of the application and leak the memory.

Recommendation

Upgrade to Adobe Photoshop CC 2018 19.1.9 or Photoshop CC 2019 20.0.6 or later. Please see the references for more information.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Aug 26, 2019
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available