HomePentest-Tools.com Logo

Adobe Shockwave Player ActiveX Control BOF Vulnerability CVE-2009-3244

Severity
Not available
CVSSv3 Score
Not available
Vulnerability description

Adobe Shockwave Player ActiveX Control is prone to a buffer overflow vulnerability.

Risk description

An error occurs in the ActiveX Control (SwDir.dll) while processing malicious user supplied data containing a long PlayerVersion property value. Successful attack could allow attackers to execute arbitrary code and to cause denial of service.

Recommendation

Upgrade to Adobe Shockwave Player 11.5.2.602.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Sep 18, 2009
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available