HomePentest-Tools.com Logo

Foxit Reader <= 8.3.1 Multiple Vulnerabilities - Linux CVE-2017-10956CVE-2017-10957CVE-2017-10958CVE-2017-10959CVE-2017-14818CVE-2017-14819CVE-2017-14820CVE-2017-14821CVE-2017-14822CVE-2017-14823CVE-2017-14824CVE-2017-14825CVE-2017-14826CVE-2017-14827CVE-2017-14828CVE-2017-14829CVE-2017-14830CVE-2017-14831CVE-2017-14832CVE-2017-14833CVE-2017-14834CVE-2017-14835CVE-2017-14836CVE-2017-14837CVE-2017-16571CVE-2017-16572CVE-2017-16573CVE-2017-16574CVE-2017-16575CVE-2017-16576CVE-2017-16577CVE-2017-16588CVE-2017-16589

Severity
CVSSv3 Score
6.5
Vulnerability description

Foxit Reader is prone to multiple code execution and information disclosure vulnerabilities.

Risk description

Foxit Reader allows information disclosure through improper validation of user input. It also allows code execution via both improper object validation and improper user input validation that leads to a type confusion condition. Successful exploitation would allow an attacker to access sensitive information or execute code on the target host.

Recommendation

Update to version 9.0 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Dec 20, 2017
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available