HomePentest-Tools.com Logo

Gale EVP_VerifyFinal Security Bypass Vulnerability CVE-2009-0047

Severity
Not available
CVSSv3 Score
Not available
Vulnerability description

Gale is prone to a security bypass vulnerability.

Risk description

The flaw is due to improper validation of return value in EVP_VerifyFinal function of openssl. Successful exploitation could allow remote attackers to bypass the certificate validation checks and can cause spoofing attacks via signature checks on DSA and ECDSA keys used with SSL/TLS.

Recommendation

No known solution was made available for at least one year since the disclosure of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer release, disable respective features, remove the product or replace the product by another one.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Jan 7, 2009
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available