HomePentest-Tools.com Logo

Apache Airflow <=1.10.10 - Command Injection CVE-2020-11981

Severity
CVSSv3 Score
9.8
Vulnerability description

An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attacker can connect to the broker (Redis, RabbitMQ) directly, it is possible to inject commands, resulting in the celery worker running arbitrary commands.\n

Risk description

No risk description to display.

Recommendation

Upgrade apache-airflow to version 1.10.11 or higher.

Codename
Not available
Detectable with
Network Scanner
Scan engine
Nuclei
Exploitable with Sniper
No
CVE Published
Jul 17, 2020
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available