HomePentest-Tools.com Logo

Apache HTTP Server 2.4.17 < 2.4.49 mod_proxy HTTP/2 Request Smuggling Vulnerability - Windows CVE-2021-33193

Severity
CVSSv3 Score
7.5
Vulnerability description

Apache HTTP Server is prone to an HTTP/2 request smuggling vulnerability in the mod_proxy module.

Risk description

Apaches mod_proxy allows spaces in the :method of HTTP/2 requests, enabling request line injection. If the back-end server tolerates trailing junk in the request line, this lets an attacker to bypass block rules.

Recommendation

Update to version 2.4.49 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Aug 16, 2021
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available