HomePentest-Tools.com Logo

Apache HTTP Server < 2.4.48 NULL Pointer Dereference Vulnerability - Windows CVE-2021-31618

Severity
CVSSv3 Score
7.5
Vulnerability description

Apache HTTP Server is prone to a NULL pointer dereference vulnerability.

Risk description

Apache HTTP Server protocol handler for the HTTP/2 protocol checks received request headers against the size limitations as configured for the server and used for the HTTP/1 protocol as well. On violation of these restrictions an HTTP response is sent to the client with a status code indicating why the request was rejected. This rejection response was not fully initialised in the HTTP/2 protocol handler if the offending header was the very first one received or appeared in a footer. This led to a NULL pointer dereference on initialised memory, crashing reliably the child process. Successful exploitation will allow an attacker to crash the server.

Recommendation

Update to version 2.4.48 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Jun 15, 2021
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available