HomePentest-Tools.com Logo

Apache Struts 2 - Remote Code Execution CVE-2019-0230

Severity
CVSSv3 Score
9.8
Vulnerability description

Apache Struts 2 is affected by a Remote Code Execution, when evaluating tags attributes. Versions vulnerable are those less than 2.5.20. The root cause of this vulnerability consists in insufficient validation of user input that is parsed by the Struts 2 Framework. This allows a malicious unauthenticated attacker to execute arbitrary code on the server.

Risk description

The risk exists that a remote unauthenticated attacker can fully compromise the Apache server in order to steal confidential information, install ransomware or pivot to the internal network.

Exploit capabilities

Sniper can gain unauthenticated Remote Code Execution on the target system and extract multiple artefacts as evidence.

Recommendation

Upgrade the Apache Struts 2 Framework to the latest version or to a version higher or equal than 2.5.22.

Codename
Not available
Detectable with
Network Scanner
Scan engine
Sniper
Exploitable with Sniper
Yes
CVE Published
Aug 1, 2020
Detection added at
Software Type
Web framework
Vendor
Apache
Product
Struts