HomePentest-Tools.com Logo

Apache Tapestry 5.4.0 < 5.6.3, 5.7.0 < 5.7.1 RCE Vulnerability - Active Check CVE-2021-27850

Severity
CVSSv3 Score
9.8
Vulnerability description

Apache Tapestry is prone to a remote code execution (RCE) vulnerability.

Risk description

An unauthenticated remote code execution vulnerability was found in Apache Tapestry. The vulnerability is a bypass of the fix for CVE-2019-0195. Before the fix of CVE-2019-0195 it was possible to download arbitrary class files from the classpath by providing a crafted asset file URL. An attacker was able to download the file AppModule.class by requesting the path /assets/something/services/AppModule.class which contains a HMAC secret key. The fix for that bug was a blacklist filter that checks if the URL ends with .class, .properties or .xml. Unfortunately, the blacklist solution can simply be bypassed by appending a / at the end of the path: /assets/something/services/AppModule.class/ The slash is stripped after the blacklist check and the file AppModule.class is loaded into the response. This class usually contains the HMAC secret key which is used to sign serialized Java objects. With the knowledge of that key an attacker can sign a Java gadget chain that leads to RCE (e.g. CommonsBeanUtils1 from ysoserial).

Recommendation

Update to version 5.6.3, 5.7.1 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Apr 15, 2021
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available