HomePentest-Tools.com Logo

Apache Tomcat Information Disclosure Vulnerability (Mar 2023) - Windows CVE-2023-28708

Severity
CVSSv3 Score
4.3
Vulnerability description

Apache Tomcat is prone to an information disclosure vulnerability.

Risk description

When using the RemoteIpFilter with requests received from a reverse proxy via HTTP that include the X-Forwarded-Proto header set to https, session cookies created by Tomcat did not include the secure attribute. This could result in the user agent transmitting the session cookie over an insecure channel.

Recommendation

Update to version 8.5.86, 9.0.72, 10.1.6, 11.0.0-M3 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Mar 22, 2023
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available