HomePentest-Tools.com Logo

Check MK < 1.6.0p25, 2.0.x < 2.0.0p4 XSS Vulnerability CVE-2021-36563

Severity
CVSSv3 Score
5.4
Vulnerability description

Check MK is prone to a cross-site scripting (XSS) vulnerability in the management web console.

Risk description

The CheckMK management web console does not sanitise user input in various parameters of the WATO module. This allows an attacker to open a backdoor on the device with HTML content and interpreted by the browser (such as JavaScript or other client-side scripts), the XSS payload will be triggered when the user accesses some specific sections of the application. In the same sense a very dangerous potential way would be when an attacker who has the monitor role (not administrator) manages to get a stored XSS to steal the secretAutomation (for the use of the API in administrator mode) and thus be able to create another administrator user who has high privileges on the CheckMK monitoring web console. Another way is that persistent XSS allows an attacker to modify the displayed content or change the victims information. Successful exploitation requires access to the web management interface, either with valid credentials or with a hijacked session.

Recommendation

Update to version 1.6.0p25, 2.0.0p4 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Jul 26, 2021
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available