HomePentest-Tools.com Logo

Drupal jQuery XSS Vulnerability (SA-CORE-2019-006) (Windows) CVE-2019-11358

Severity
CVSSv3 Score
6.1
Vulnerability description

Drupal is prone to a cross-site scripting vulnerability in jQuery.

Risk description

jQuery 3.4.0 includes a fix for some unintended behavior when using jQuery.extend(true, {}, ...). If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype. This fix is included in jQuery 3.4.0, but patch diffs exist to patch previous jQuery versions.

Recommendation

Update to version 7.66, 8.5.15, 8.6.15 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Apr 20, 2019
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available