HomePentest-Tools.com Logo

Grafana XSS Vulnerability (GHSA-3j9m-hcv9-rpj8) CVE-2021-41174

Severity
CVSSv3 Score
6.1
Vulnerability description

Grafana is prone to a cross-site scripting (XSS) vulnerability.

Risk description

In affected versions if an attacker is able to convince a victim to visit a URL referencing a vulnerable page, arbitrary JavaScript content may be executed within the context of the victims browser. The user visiting the malicious link must be unauthenticated and the link must be for a page that contains the login button in the menu bar. The url has to be crafted to exploit AngularJS rendering and contain the interpolation binding for AngularJS expressions. AngularJS uses double curly braces for interpolation binding: {{ }}. When the user follows the link and the page renders, the login button will contain the original link with a query parameter to force a redirect to the login page. The URL is not validated and the AngularJS rendering engine will execute the JavaScript expression contained in the URL.

Recommendation

Update to version 8.2.3 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Nov 3, 2021
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available