HomePentest-Tools.com Logo

Apache Struts Security Update (S2-031) CVE-2016-3082

Severity
CVSSv3 Score
9.8
Vulnerability description

Apache Struts is prone to an arbitrary code execution vulnerability.

Risk description

The flaw exists as XSLTResult allows for the location of a stylesheet being passed as a request parameter. Successful exploitation will allow remote attackers to execute arbitrary code.

Recommendation

Update to version 2.3.20.3, 2.3.24.3, 2.3.28.1 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Apr 26, 2016
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available