HomePentest-Tools.com Logo

Apache Struts Security Update (S2-052) - Active Check CVE-2017-9805

Severity
CVSSv3 Score
8.1
Vulnerability description

Apache Struts is prone to a remote code execution (RCE) vulnerability.

Risk description

The flaw exists within the REST plugin which is using a XStreamHandler with an instance of XStream for deserialization without any type filtering. Successfully exploiting this issue may allow an attacker to execute arbitrary code in the context of the affected application. Failed exploit attempts will likely result in denial-of-service conditions.

Recommendation

Update to version 2.3.34, 2.5.13 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Sep 15, 2017
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available