HomePentest-Tools.com Logo

DiY-CMS Multiple Remote File Inclusion Vulnerabilities CVE-2010-3206

Severity
Not available
CVSSv3 Score
Not available
Vulnerability description

DiY-CMS is prone to multiple remote file inclusion vulnerabilities.

Risk description

Multiple flaws are due to: - An error in modules/guestbook/blocks/control.block.php, which is not properly validating the input passed to the lang parameter. - An error in the index.php, which is not properly validating the input passed to main_module parameter. - An error in the includes/general.functions.php, which is not properly validating the input passed to getFile parameter. Successful exploitation will allow attacker to execute arbitrary code on the vulnerable Web server.

Recommendation

No known solution was made available for at least one year since the disclosure of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer release, disable respective features, remove the product or replace the product by another one.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Sep 3, 2010
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available