HomePentest-Tools.com Logo

Eggdrop < 1.6.19 Server Module Message Handling Remote Buffer Overflow Vulnerability CVE-2007-2807

Severity
Not available
CVSSv3 Score
Not available
Vulnerability description

Eggdrop Server Module is prone to a remote buffer-overflow vulnerability because the application fails to bounds-check user-supplied data before copying it into an insufficiently sized buffer.

Risk description

An attacker can exploit this issue to execute arbitrary code within the context of the affected application. Failed exploit attempts will result in a denial-of-service condition.

Recommendation

Update to version 1.6.19 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
May 22, 2007
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available