HomePentest-Tools.com Logo

Elastic Elasticsearch Information Disclosure Vulnerability (ESA-2021-05) CVE-2021-22134

Severity
CVSSv3 Score
4.3
Vulnerability description

Elasticsearch is prone to an information disclosure vulnerability.

Risk description

A document disclosure flaw was found in Elasticsearch when Document or Field Level Security is used. Get requests do not properly apply security permissions when executing a query against a recently updated document. This affects documents that have been updated and not yet refreshed in the index. This could result in the search disclosing the existence of documents and fields the attacker should not be able to view. A mitigating factor to this flaw is an attacker must know the document ID to run the get request.

Recommendation

Update to version 7.11.0 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Mar 8, 2021
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available