HomePentest-Tools.com Logo

Drupal 7.x < 7.82, 8.0.x < 8.9.17, 9.x < 9.1.11, 9.2.x < 9.2.2 Archive_Tar library Vulnerability (SA-CORE-2021-004) - Windows CVE-2021-32610

Severity
CVSSv3 Score
7.1
Vulnerability description

Drupal is prone to a vulnerability in the third-party library Archive_Tar.

Risk description

The Drupal project uses the pear Archive_Tar library, which has released a security update that impacts Drupal. The vulnerability is mitigated by the fact that Drupal cores use of the Archive_Tar library is not vulnerable, as it does not permit symlinks. Exploitation may be possible if contrib or custom code uses the library to extract tar archives (for example .tar, .tar.gz, .bz2, or .tlz) which come from a potentially untrusted source.

Recommendation

Update to version 7.82, 8.9.17, 9.1.11, 9.2.2 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Jul 30, 2021
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available