HomePentest-Tools.com Logo

Elastic Elasticsearch Privilege Escalation Vulnerability (ESA-2022-02) CVE-2022-23708

Severity
CVSSv3 Score
4.3
Vulnerability description

Elastic Elasticsearch is prone to a privilege escalation vulnerability.

Risk description

A flaw was discovered in Elasticsearchs upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with * index permissions access to this index.

Recommendation

Update to version 7.17.1 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Mar 3, 2022
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available