HomePentest-Tools.com Logo

Oracle WebLogic - Remote Code Execution CVE-2020-2555

Severity
CVSSv3 Score
9.8
Vulnerability description

Oracle Weblogic is affected by a Remote Code Execution vulnerability inside the core component. The root cause of this vulnerability is an insecure deserialization via T3, IIOP protocols that could allow an unauthenticated attacker to take control of the server. The attacker can send a crafted malicious object in order to achieve access to the server.

Risk description

The risk exists that a remote unauthenticated attacker can fully compromise the server in order to steal confidential information, install ransomware, or pivot to the internal network.

Exploit capabilities

Sniper can gain unauthenticated Remote Code Execution on the target system and extract multiple artefacts as evidence.

Recommendation

Apply the security patch for the Oracle Weblogic server.

Codename
Not available
Detectable with
Network Scanner
Scan engine
Sniper
Exploitable with Sniper
Yes
CVE Published
Jan 15, 2020
Detection added at
Software Type
Web server
Vendor
Oracle
Product
WebLogic