HomePentest-Tools.com Logo

HHVM Multiple Vulnerabilities (Mar 2020) CVE-2020-1888CVE-2020-1892CVE-2020-1893

Severity
CVSSv3 Score
7.5
Vulnerability description

HHVM is prone to multiple vulnerabilities.

Risk description

The following vulnerabilities exist: - Insufficient boundary checks when decoding JSON in handleBackslash allow reading out of bounds memory. - Insufficient boundary checks when decoding JSON in JSON_parser allow reading out of bounds memory. - Insufficient boundary checks when decoding JSON in TryParse allow reading out of bounds memory. Successful exploitation would allow an attacker to cause a denial of service or read sensitive information.

Recommendation

Update to version 4.8.7, 4.32.1, 4.38.1, 4.39.1, 4.40.1, 4.41.1, 4.42.1, 4.43.1, 4.44.1 or 4.45.1 respectively.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Mar 3, 2020
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available