HomePentest-Tools.com Logo

Discourse < 2.4.0.beta2 Multiple Vulnerabilities CVE-2019-1020017CVE-2019-1020018

Severity
CVSSv3 Score
7.3
Vulnerability description

Discourse is prone to multiple vulnerabilities including XSS and SQL injection flaws.

Risk description

The following flaws exist / The following security fixes are included: - XSS when displaying watched words in admin panel - SQL injection with default categories - Upgrade lodash - XSS with title selector on preferences page - Strip HTML from invite emails - XSS in routes - Escape email text for posts containing [details]. - lacks a confirmation screen when logging in via an email link (CVE-2019-1020018). - lacks a confirmation screen when logging in via a user-api OTP (CVE-2019-1020017).

Recommendation

Update to version 2.4.0.beta2.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Jul 29, 2019
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available