HomePentest-Tools.com Logo

Cacti < 1.2.8 Multiple Vulnerabilities - Windows CVE-2019-17358CVE-2019-17357

Severity
CVSSv3 Score
8.1
Vulnerability description

Cacti is prone to multiple vulnerabilities.

Risk description

The following vulnerabilities exist: - There are multiple instances of lib/functions.php unsafe deserialization of user-controlled data to populate arrays. An authenticated attacker could use this to influence object data values and control actions taken by Cacti or potentially cause memory corruption in the PHP module. - There is an SQL injection vulnerability via graphs.php?template_id affecting how template identifiers are handled when a string and id composite value are used to identify the template type and id. An authenticated attacker can exploit this to extract data from the database, or an unauthenticated attacker could exploit this via Cross-Site Request Forgery.

Recommendation

Update to version 1.2.8 or later.

Codename
Not available
Detectable with
Network Scanner
Scan engine
OpenVAS
Exploitable with Sniper
No
CVE Published
Jan 21, 2020
Detection added at
Software Type
Not available
Vendor
Not available
Product
Not available